Hello...hesitation after turbocharging - Newbies Forum

Forum Post / Reply
You must log in before you can post or reply to messages.
Hello...hesitation after turbocharging
Wednesday, October 26, 2016 11:31 AM

hey. i was kinda lurking around here before i started this project and maybe you can help me

so i have a 2000 s10 with the 2.2 and i just wrapped up installing a turbo charger.

i figured since this place seems to be a bit more "performancy" than the s10 forum i think you guys might be the right place to ask

anyway. so i fire the truck up and it starts good and idles good. but when i give it gas it'll hesitate.

like you can blip the throttle and sorta get it reved up. or push it just a tiny bit and get the motor going and then give it more. but just normally pressing down the peddle it kind of hesitates and

like the computer cut the fuel regardless if youre on the gas.

for fuel ive just got an fmu with a 10:1 (i think) and the stock pump and injectors. my internal wastegate is set to 5 psi.

i had an idea that maybe it was cutting out cause of the turbo but the hesitation pretty much keeps it from reving high enough to make boost. so its a pre boost issue i think. i was able to kinda tap on the gas just to rev it up to hear the spool.

man it was sweet lol

OH and im running the TR6 spark plugs. i read from here people go one step colder. theyre gapped at .035
20161026_115415.jpg (503k)

Re: Hello...hesitation after turbocharging
Wednesday, October 26, 2016 11:24 PM
T!M8!T Online
I cant help much here but i kno both 2.2 and eco tend to have a hesitant. Ppl have tried many things but i dont think anyone really figured it out completly. Few ideas maybe check ur vaccum lines, distributor, filters, sensors/connectors. I kno even certain gas can cuz the issue. What bout a boost timer? Maybe someone more advance can input. Good luck

ReD RaiN
Re: Hello...hesitation after turbocharging
Thursday, October 27, 2016 5:13 AM
im thinking the MAP sensor might be on the fritz. i was thinking about it earlier at work. i googled "symptoms of a bad map sensor" and what ive read is pretty much exactly what im experiencing. Im gonna bring it to work tomorrow night and try it out on a co-worker's 2.2 sonoma

Also im 100% the gas inst that great as the truck has been sitting for, maybe a year? i work at an airport and can get 100LL fuel... i was joking with a friend id dump a few gallons in the tank and maybe it would blow all the cobwebs out haha
Re: Hello...hesitation after turbocharging
Sunday, October 30, 2016 1:14 PM
If you have a graphing scan tool I'd look at the voltage from your tps sometimes a vehicle will develop dead spots in signal due to a faulty tps. The cel may or may not light depending on wether or not the sensor is within " spec" but still not a consistent reading regarding actual throttle pos
Ase L1 master tech
Re: Hello...hesitation after turbocharging
Saturday, April 29, 2017 7:12 PM
Might be from having no air reserve in the intake anymore. If you notice on most stock intakes you will see random cylinders or pockets with seemingly no purpose. But they are they for when you give it gas, it will use the air in the pockets for a better throttle response.
But I have no idea how bad your hesitation is.
Forum Post / Reply
You must log in before you can post or reply to messages.


Start New Topic Advanced Search